[PATCH] D22683: [ELF] Symbol assignment within input section list

Eugene Leviant via llvm-commits llvm-commits at lists.llvm.org
Tue Aug 2 15:04:53 PDT 2016


среда, 3 августа 2016 г. пользователь Rafael Espíndola написал:

> On 2 August 2016 at 06:00, Eugene Leviant <evgeny.leviant at gmail.com
> <javascript:;>> wrote:
> > evgeny777 added a comment.
> >
> > I think the main reason, we're using virtual input sections is that this
> the only way to calculate correct symbol offset. As you may know location
> counter is not incremented while we add input sections to output section,
> and the true size of input sections is known only after call to
> OutputSectionBase<ELFT>::assignOffsets().
>
>
> I think we should stop using OutputSection<ELFT>::assignOffsets for
> linker scripts. We can assign offsets ourselves and avoid having the
> special input section.
>


I guess createThunks should be called before assignOffsets (but strictly
after createSections) so I wonder if createThunks should be moved to
LinkerScript as well. I might not catch some architecture issues, but is
virtual input section really that bad?

Cheers,
> Rafael
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20160803/9cda97bb/attachment.html>


More information about the llvm-commits mailing list