[PATCH] D9379: llvm.noalias - don't interfere with llvm.assume

Hal Finkel via llvm-commits llvm-commits at lists.llvm.org
Thu Jul 7 16:49:55 PDT 2016


hfinkel added inline comments.

================
Comment at: lib/Analysis/ValueTracking.cpp:393
@@ -392,3 +392,3 @@
 // Is this an intrinsic that cannot be speculated but also cannot trap?
 static bool isAssumeLikeIntrinsic(const Instruction *I) {
   if (const CallInst *CI = dyn_cast<CallInst>(I))
----------------
reames wrote:
> If you're touching this code anyways, please update the name to something more clear?
Suggestions for a better name?

================
Comment at: lib/Analysis/ValueTracking.cpp:398
@@ -397,3 +397,3 @@
       default: break;
       // FIXME: This list is repeated from NoTTI::getIntrinsicCost.
       case Intrinsic::assume:
----------------
reames wrote:
> Is it time to common these two lists?
Yes. I'll do that in a separate patch.


http://reviews.llvm.org/D9379





More information about the llvm-commits mailing list