[PATCH] D21261: [CFLAA] Code cleanup: group all graph-building codes into one class

George Burgess IV via llvm-commits llvm-commits at lists.llvm.org
Mon Jun 13 17:18:43 PDT 2016


george.burgess.iv added a comment.

Looks good with one more comment.


================
Comment at: lib/Analysis/CFLAliasAnalysis.cpp:728
@@ +727,3 @@
+  const CFLGraph &getCFLGraph() { return Graph; }
+  SmallVector<Value *, 4> getReturnValues() {
+    return std::move(ReturnedValues);
----------------
...Half done?

If you want to keep the `std::move` in this accessor, that's fine -- maybe we can just rename it to something like `takeReturnValues`, or anything that makes it obvious that it's going to modify the object.


http://reviews.llvm.org/D21261





More information about the llvm-commits mailing list