[PATCH] D20337: [MC] Support symbolic expressions in assembly directives
Petr Hosek via llvm-commits
llvm-commits at lists.llvm.org
Mon May 23 20:00:33 PDT 2016
phosek added inline comments.
Comment at: include/llvm/MC/MCStreamer.h:602
@@ +601,3 @@
+ /// \param Loc - The location of the expression for error reporting.
+ virtual void emitRepeatedValue(const MCExpr *NumValues, int64_t Size,
+ int64_t Expr, SMLoc Loc = SMLoc());
> Why isn't this named EmitFill? It's of a distinct type from the other calls and is only for dealing with Fill directives and the distinction seems more confusing than multiple variants of EmitFill.
`EmitFill` is used for emitting "fill bytes" in case of directives like `.space` and `.zero` while `.fill` requires a special handling. I could rename both `emitSpace` and `emitRepeatedValue` to `EmitFill` if you prefer since it's distinct type from the other one, I just wanted to avoid confusion, but I feel like it's going to be confusing in either case.
More information about the llvm-commits