[PATCH] D20331: [llvm-mc] - Teach llvm-mc to generate compressed debug sections in zlib style.

Davide Italiano via llvm-commits llvm-commits at lists.llvm.org
Wed May 18 08:15:08 PDT 2016


davide added inline comments.

================
Comment at: lib/MC/ELFObjectWriter.cpp:576
@@ -575,4 +575,3 @@
   auto &Sec = cast<MCSectionELF>(Sym->getSection());
-  unsigned Flags = Sec.getFlags();
-  if (Flags & ELF::SHF_MERGE) {
+  if (Sec.Flags & ELF::SHF_MERGE) {
     if (C != 0)
----------------
davide wrote:
> grimar wrote:
> > davide wrote:
> > > You can change that separately, if you really like. It's unrelated, and makes the patch slightly less readable.
> > Please see my comment below.
> I can review them at the same time but they should be committed separately.
I saw your comment. There's no need to change at the same time the access control and remove the getter. Leave it private, and leave the getter to keep the patch small.  You can do that in a separate commit.


http://reviews.llvm.org/D20331





More information about the llvm-commits mailing list