[PATCH] D19167: [esan] EfficiencySanitizer instrumentation pass

Derek Bruening via llvm-commits llvm-commits at lists.llvm.org
Wed Apr 20 10:01:34 PDT 2016


bruening added inline comments.

================
Comment at: lib/Transforms/Instrumentation/EfficiencySanitizer.cpp:306
@@ +305,3 @@
+    I->eraseFromParent();
+    Res = true;
+  } else
----------------
filcab wrote:
> The three cases above can be written more succintly (and made easier to follow/spot (lack of) differences).
> Check out `AddressSanitizer::instrumentMemIntrinsic`.
> 
Reviewer ping-pong :)  Please see the original version of this code in the first patchset, which matched what asan had, and the reviewer comment above asking to change it to the current form.


http://reviews.llvm.org/D19167





More information about the llvm-commits mailing list