[PATCH] D19046: Introduce a "patchable-prologue" function attribute

Reid Kleckner via llvm-commits llvm-commits at lists.llvm.org
Wed Apr 13 13:10:42 PDT 2016


rnk accepted this revision.
rnk added a comment.
This revision is now accepted and ready to land.

lgtm with the adjusted naming


================
Comment at: include/llvm/Target/TargetFrameLowering.h:326
@@ +325,3 @@
+
+  enum PatchablePrologueFlavor { PPF_HOTPATCH_COMPACT, PPF_UNKNOWN };
+
----------------
Why not "Kind" instead of "Flavor"? That's way more common across LLVM. Also, our enum naming convention would make this look like:
  enum PatchablePrologueKind { PPF_HotpatchCompact, PPF_Unknown };
http://llvm.org/docs/CodingStandards.html#name-types-functions-variables-and-enumerators-properly


http://reviews.llvm.org/D19046





More information about the llvm-commits mailing list