[PATCH] D18960: [lld] Initial implementation of TLSDESC relocation handling
Rui Ueyama via llvm-commits
llvm-commits at lists.llvm.org
Mon Apr 11 15:08:32 PDT 2016
ruiu added a comment.
This seems to conflict with http://reviews.llvm.org/D18711, so you may want to wait for that.
Comment at: ELF/InputSection.cpp:301
@@ +300,3 @@
+ Target->relocateOne(BufLoc, BufEnd, Type, AddrLoc,
+ Body.getGotPltTlsDescVA<ELFT>() + A);
I'd name this getTlsDescVA rather than getGotPltTlsDescVA if there's no reason to include "GotPlt".
Comment at: ELF/OutputSections.h:164
@@ -156,3 +163,3 @@
- std::vector<const SymbolBody *> Entries;
+ std::vector<std::vector<const SymbolBody *>> Entries;
This code is hard to understand. If I understand it correctly, it is a vector of vectors binned according to their DynReloc_* types. Is this correct?
There seems to be no reason to aggregate multiple vectors into one vector (of vectors) here. Why don't you define multiple vectors?
More information about the llvm-commits