[PATCH] D18004: [ELF] - refactor of SymbolBody::compare()

George Rimar via llvm-commits llvm-commits at lists.llvm.org
Wed Mar 9 11:15:10 PST 2016


grimar added inline comments.

================
Comment at: ELF/Symbols.cpp:149
@@ -142,3 +148,3 @@
     return -1;
-  if (!std::get<0>(L) || !std::get<1>(L) || !std::get<2>(L))
+  if (!isDefined() || isShared() || isWeak())
     return 1;
----------------
And I think direct names are more readable than std::get<>


http://reviews.llvm.org/D18004





More information about the llvm-commits mailing list