[PATCH] D17829: [libfuzzer] arbitrary function adapter

Evgeniy Stepanov via llvm-commits llvm-commits at lists.llvm.org
Thu Mar 3 11:47:27 PST 2016


eugenis added a comment.

I'm not sure about the whole idea of splitting an array of bytes into multiple arguments. It seems like a lot of mutations in the input byte array would result in very non-local changes to the argument list, ex. inserting a byte at the beginning would shift all arguments to the right which could give them an entirely different meaning.

Would it be better to expose individual arguments to the fuzzing engine?


================
Comment at: lib/Fuzzer/FuzzerFnAdapter.h:104
@@ +103,3 @@
+    typename std::enable_if <
+    N<std::tuple_size<TupleT>::value, bool>::type
+    UnpackImpl(const uint8_t *Data, size_t Size, TupleT *Tuple) {
----------------
Space around "<" in "N<std::tuple_size" would greatly help readability.
Did you run this through clang-format?



http://reviews.llvm.org/D17829





More information about the llvm-commits mailing list