[PATCH] D15494: [ELF] - implemented @indntpoff (x86) relocation and its optimization.

George Rimar via llvm-commits llvm-commits at lists.llvm.org
Wed Dec 16 01:23:21 PST 2015


grimar added inline comments.

================
Comment at: ELF/OutputSections.cpp:225
@@ -224,3 +224,3 @@
     P->setSymbolAndType(Body->getDynamicSymbolTableIndex(),
-                        Target->getTlsGotReloc(), Config->Mips64EL);
+                        Target->getTlsGotReloc(-1), Config->Mips64EL);
     P->r_offset = Out<ELFT>::Got->getEntryAddr(*Body);
----------------
ruiu wrote:
> Oh this is worse than before. I didn't expect that you had to use a magic number instead of a default parameter. Default parameter is better.
Yep. Reverted back.


http://reviews.llvm.org/D15494





More information about the llvm-commits mailing list