[PATCH] D15531: Change linkInModule to take a std::unique_ptr

whitequark via llvm-commits llvm-commits at lists.llvm.org
Tue Dec 15 08:07:58 PST 2015


whitequark added inline comments.

================
Comment at: test/Bindings/OCaml/linker.ml:58
@@ -57,3 +57,1 @@
-    dispose_module m1;
-    dispose_module m2
 
----------------
This is really terrible; this is a silent change that alters correctness of existing OCaml code, leading to double free, which will not be detected if you don't run a Debug build of LLVM (and even then I'm not sure).

Could you please rename link_modules function to link_modules' (note the apostrophe) and add a bit to documentation in the mli like you did in the C API? It is probably not necessary to keep the old one for compatibility.

This should be a straightforward search-and-replace job, but ping me if it causes issues.


http://reviews.llvm.org/D15531





More information about the llvm-commits mailing list