[PATCH] D15307: [Polly] ScopInfo: Harmonize the different ARRAY_KINDs

Tobias Grosser via llvm-commits llvm-commits at lists.llvm.org
Thu Dec 10 02:40:38 PST 2015


grosser marked an inline comment as not done.
grosser added a comment.

Hi Michael,

thank your for your comments. The latest patch should address all your comments. Can you have a final look?


================
Comment at: include/polly/ScopInfo.h:312
@@ -203,3 +311,3 @@
   /// normal scalar array modeling.
-  bool isPHI() const { return Kind == KIND_PHI; };
+  bool isPHI() const { return Kind == MK_PHI; };
 
----------------
Meinersbur wrote:
> Rename to hasKindPHI() for consistency with MemoryAccess::hasKindPHI?
Changed.

================
Comment at: include/polly/ScopInfo.h:603-604
@@ -581,3 +602,4 @@
                ArrayRef<const SCEV *> Subscripts, ArrayRef<const SCEV *> Sizes,
-               Value *AccessValue, AccessOrigin Origin, StringRef BaseName);
+               Value *AccessValue, ScopArrayInfo::MemoryKind Kind,
+               StringRef BaseName);
   ~MemoryAccess();
----------------
Meinersbur wrote:
> The style guide also seem to prefer consistency with existing styles. enum AccessType uses all caps values. We could change it as well (in a different patch).
Good idea.

================
Comment at: include/polly/ScopInfo.h:699
@@ -676,3 +698,3 @@
   /// @brief Whether this is an access of an explicit load or store in the IR.
-  bool isExplicit() const { return Origin == EXPLICIT; }
+  bool hasKindArray() const { return Kind == ScopArrayInfo::MK_Array; }
 
----------------
Meinersbur wrote:
> Personally, I'd prefer isArrayKind() or isArrayAccess(). No objective reasons.
I do not feel strong about this. Changed to isArrayKind.


http://reviews.llvm.org/D15307





More information about the llvm-commits mailing list