[PATCH] D14780: Add calling convention for C++ TLS on Darwin

Lang Hames via llvm-commits llvm-commits at lists.llvm.org
Thu Dec 3 10:56:46 PST 2015


lhames added a comment.

Perhaps a less generic name would be good, since not all platforms will use cxx_tlscc for C++ TLS. Maybe 'darwin_cxx_tlscc' as Sean suggested, or 'cxx_fast_tlscc'?

Otherwise this looks good to me. :)


================
Comment at: docs/LangRef.rst:410-411
@@ +409,4 @@
+"``cxx_tlscc``" - The `CXX_TLS` calling convention for access functions
+    This calling convention attempts to make the code in the caller as little
+    intrusive as possible. This calling convention behaves identical to the `C`
+    calling convention on how arguments and return values are passed, but it
----------------
I think this should be "...attempts to make the code as non-intrusive as possible." or "This calling convention aims to minimize overhead in the caller by preserving as many registers as possible".


Repository:
  rL LLVM

http://reviews.llvm.org/D14780





More information about the llvm-commits mailing list