[PATCH] D12475: [LV] Pull creation of trip counts into a helper function.

James Molloy via llvm-commits llvm-commits at lists.llvm.org
Wed Sep 2 10:37:47 PDT 2015


This is what I get for skimming until the last comment :(

Sorry Adam, I'll make that change first thing in the morning.

On Wed, 2 Sep 2015 at 18:32 Adam Nemet via llvm-commits <
llvm-commits at lists.llvm.org> wrote:

> anemet added inline comments.
>
> ================
> Comment at: lib/Transforms/Vectorize/LoopVectorize.cpp:2617-2618
> @@ +2616,4 @@
> +  // Find the loop boundaries.
> +  const SCEV *ExitCount = SE->getBackedgeTakenCount(OrigLoop);
> +  assert(ExitCount != SE->getCouldNotCompute() && "Invalid loop count");
> +
> ----------------
> anemet wrote:
> > I'll let Michael give final OK but since you're cleaning this up, it
> would be good to finally rename this to BackedgeTakenCount or something.
> Later the code redefines this same variable to the *real* exit count which
> is pretty crazy.  These two values should be different variables.
> Looks like you didn't make this change in the commit.
>
>
> Repository:
>   rL LLVM
>
> http://reviews.llvm.org/D12475
>
>
>
> _______________________________________________
> llvm-commits mailing list
> llvm-commits at lists.llvm.org
> http://lists.llvm.org/cgi-bin/mailman/listinfo/llvm-commits
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20150902/5bfb47b7/attachment.html>


More information about the llvm-commits mailing list