[PATCH] D12475: [LV] Pull creation of trip counts into a helper function.

Adam Nemet via llvm-commits llvm-commits at lists.llvm.org
Tue Sep 1 23:30:00 PDT 2015


anemet added inline comments.

================
Comment at: lib/Transforms/Vectorize/LoopVectorize.cpp:2617-2618
@@ +2616,4 @@
+  // Find the loop boundaries.
+  const SCEV *ExitCount = SE->getBackedgeTakenCount(OrigLoop);
+  assert(ExitCount != SE->getCouldNotCompute() && "Invalid loop count");
+
----------------
I'll let Michael give final OK but since you're cleaning this up, it would be good to finally rename this to BackedgeTakenCount or something.  Later the code redefines this same variable to the *real* exit count which is pretty crazy.  These two values should be different variables.


Repository:
  rL LLVM

http://reviews.llvm.org/D12475





More information about the llvm-commits mailing list