[PATCH] D11481: [LoopUnswitch] Improve loop unswitch pass to find trivial unswitch conditions more effectively

Chen Li meloli87 at gmail.com
Fri Jul 24 11:44:01 PDT 2015

chenli added inline comments.

Comment at: lib/Transforms/Scalar/LoopUnswitch.cpp:808
@@ +807,3 @@
+    HeaderTerm = Header->getTerminator();
+  }
broune wrote:
> Nit: HeaderTerm is set twice and only used twice. I would use Header->getTerminator() directly for the two uses instead, as then there's one variable less to keep track of.
There are a few uses in the later code as well. I would prefer to keep the variable.


More information about the llvm-commits mailing list