[llvm] r242409 - [Codegen] Add intrinsics 'absdiff' and corresponding SDNodes for absolute difference operation

Bruno Cardoso Lopes bruno.cardoso at gmail.com
Thu Jul 23 07:10:45 PDT 2015


Hi Asghar,

Thanks for working on this :-)

On Thu, Jul 16, 2015 at 12:22 PM, James Molloy <james.molloy at arm.com> wrote:
> Author: jamesm
> Date: Thu Jul 16 10:22:46 2015
> New Revision: 242409
>
> URL: http://llvm.org/viewvc/llvm-project?rev=242409&view=rev
> Log:
> [Codegen] Add intrinsics 'absdiff' and corresponding SDNodes for absolute difference operation
>
> This adds new intrinsics "*absdiff" for absolute difference ops to facilitate efficient code generation for "sum of absolute differences" operation.
> The patch also contains the introduction of corresponding SDNodes and basic legalization support.Sanity of the generated code is tested on X86.
>
> This is 1st of the three patches.
>
> Patch by Shahid Asghar-ahmad!
>
> Added:
>     llvm/trunk/test/CodeGen/X86/absdiff_expand.ll

Could you please split and rename it to vector-absdiff-128.ll and
vector-absdiff-256.ll? No need to split files based on the fact that
they are testing the expansion. Once you have custom versions, just
drive them by subtarget features (+ssse3, sse4*, etc). Take a look at
vector-blend.ll and others for examples.

-- 
Bruno Cardoso Lopes
http://www.brunocardoso.cc



More information about the llvm-commits mailing list