[PATCH] D11276: [LoopUnswitch] Code refactoring to separate trivial loop unswitch and non-trivial loop unswitch in processCurrentLoop()

Chen Li meloli87 at gmail.com
Tue Jul 21 12:49:12 PDT 2015

chenli updated this revision to Diff 30280.
chenli added a comment.

Update w.r.t Philip's comments.

After inlining isTrivialUnswitchCondition() into TryTrivialLoopUnswitch(), isTrivialUnswitchCondition() is basically dead code (no use anywhere). A following patch will be submitted to clean it up.



-------------- next part --------------
A non-text attachment was scrubbed...
Name: D11276.30280.patch
Type: text/x-patch
Size: 5990 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20150721/c288fac3/attachment.bin>

More information about the llvm-commits mailing list