[PATCH] D11250: Rename LoopInfo::Analyze() to LoopInfo::analyze() and turn its parameter type to const&.

Cong Hou congh at google.com
Wed Jul 15 16:51:21 PDT 2015


congh created this revision.
congh added a reviewer: dexonsmith.
congh added subscribers: llvm-commits, davidxl.

The benefit of turning the parameter of LoopInfo::analyze() to const& is that it now can accept a rvalue.

http://reviews.llvm.org/D11250

Files:
  include/llvm/Analysis/LoopInfo.h
  include/llvm/Analysis/LoopInfoImpl.h
  include/llvm/CodeGen/MachineDominators.h
  include/llvm/IR/Dominators.h
  lib/Analysis/LoopInfo.cpp
  lib/CodeGen/MachineLoopInfo.cpp

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D11250.29841.patch
Type: text/x-patch
Size: 4528 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20150715/42f7f145/attachment.bin>


More information about the llvm-commits mailing list