[PATCH] D11239: [LoopUnswitch] Add an else clause to IsTrivialUnswitchCondition() when checking HeaderTerm instruction type

Philip Reames listmail at philipreames.com
Wed Jul 15 14:14:52 PDT 2015


reames accepted this revision.
reames added a comment.
This revision is now accepted and ready to land.

LGTM.


================
Comment at: lib/Transforms/Scalar/LoopUnswitch.cpp:644
@@ -643,1 +643,3 @@
     }
+  } else {
+    // TrivialUnswitchCondition can only apply to BranchInst or SwitchInst.
----------------
The comment doesn't seem to add much value.  Possibly remove?

No need for curly braces.  


http://reviews.llvm.org/D11239







More information about the llvm-commits mailing list