[PATCH] Remove DataLayout access from the TargetMachine, redirect to the Module

Mehdi AMINI mehdi.amini at apple.com
Mon Jun 29 17:06:33 PDT 2015


REPOSITORY
  rL LLVM

================
Comment at: include/llvm/Analysis/TargetTransformInfo.h:680
@@ -676,3 +679,3 @@
                              unsigned AddrSpace) override {
-    return Impl.isLegalAddressingMode(Ty, BaseGV, BaseOffset, HasBaseReg,
-                                      Scale, AddrSpace);
+    return Impl.isLegalAddressingMode(Ty, BaseGV, BaseOffset, HasBaseReg, Scale,
+                                      AddrSpace);
----------------
rafael wrote:
> Changes like this make the patch harder to read. Can you git-clang-format it?
I clang-formatted the patch, I assume this is why this particular line is changed (the original line was not clang-formatted).

Now there is no reason that git clang-format would create a separate hunk, so I probably had to touch it in an intermediate version.

http://reviews.llvm.org/D10823

EMAIL PREFERENCES
  http://reviews.llvm.org/settings/panel/emailpreferences/






More information about the llvm-commits mailing list