[PATCH] [Inlining] Teach the inliner pass to inline through statepoints.

Sanjoy Das sanjoy at playingwithpointers.com
Thu Jun 25 19:18:38 PDT 2015


================
Comment at: include/llvm/IR/CallSite.h:107
@@ -105,1 +106,3 @@
 
+  FunTy *getMetaCallDestination() const {
+    FunTy *LiteralDest = getCalledFunction();
----------------
pgavlin wrote:
> reames wrote:
> > a) comments!  both here on getCalledFunction to distinguish
> > b) naming - "meta" isn't real descriptive.  Possible getCalledFunctionUnwrapped?
> This feels a bit ugly to me, esp. since the information about the location of the actual callee in the statepoint argument list is also present as a constant in Statepoint.h. Would it perhaps make sense to split StatepointBase into 2 types--a base type that provides argument accessors and can be included next to `CallSite`, and a derived type that provides `getRelocates()`?
> 
> Bikeshedding a bit, I'd probably also rename this to `getActualCalledFunction()` or similar.
I think there is scope to (at least) extract out a `StatepointOffsets` struct with all of the constants encoded as `static const int`s and include that in CallSite.h as well as Statepoint.h.  Do you think something like that will be sufficient?

http://reviews.llvm.org/D10633

EMAIL PREFERENCES
  http://reviews.llvm.org/settings/panel/emailpreferences/






More information about the llvm-commits mailing list