[PATCH] When stripping debug info, also rewrite @llvm.debugtrap to @llvm.trap.
wichard at vitalitystudios.com
Wed Jun 24 14:06:48 PDT 2015
In http://reviews.llvm.org/D10349#190766, @echristo wrote:
> Seems odd, why not just remove it since it's supposed to be "for a debugger"
> (For the record, I have no dog in this show, just asking about the logic.)
Sorry 'bout the delay in getting back to you.
Honestly, I hadn't thought of that. Now that I have, I'd say rewriting to @llvm.trap is better because (I speculate) it would be the least surprising behaviour to developers.
More information about the llvm-commits