[PATCH] Add read_write_arg_mem attribute

hfinkel at anl.gov hfinkel at anl.gov
Mon Jun 22 17:49:20 PDT 2015

In http://reviews.llvm.org/D10398#190292, @igor-laevsky wrote:

> @reames,
>   ...
>   For this reason, I'd be tempted to rename this as "access_arg_mem_only" or something. Before actually doing that mechanical change, please raise this in an email to llvmdev. I think this needs broader attention. (In particular, I wouldn't feel comfortable signing off on this. The scope is too large.)

I agree with this suggestion, access or accesses is better. I also agree that we should discuss this on llvmdev, as with any other change to the IR.

> ...



More information about the llvm-commits mailing list