[PATCH] Use function attribute "arm-restrict-it"

Akira Hatanaka ahatanak at gmail.com
Mon Jun 22 11:43:46 PDT 2015

Comment at: lib/Target/ARM/ARMSubtarget.cpp:320
@@ -330,1 +319,3 @@
+bool ARMSubtarget::restrictIT(const Function &F) const {
+  // The default behavior is to disallow generation of deprecated IT blocks
compnerd wrote:
> Bikeshedding: I think that restrictedIT might be a better name.  IIRC, the ARM ARM refers to this as Restricted IT Blocks.
I'm not sure whether restrictIT is a good name or not, but if we are going to rename it, should we use a verb like "useRestrictedIT" as llvm's coding style guide recommends?



More information about the llvm-commits mailing list