[llvm] r239552 - Generalize emitAbsoluteSymbolDiff.
rafael.espindola at gmail.com
Tue Jun 16 12:47:28 PDT 2015
>> I don't think it should be renamed.
> Which one? emitLabelDifference() or emitSectionOffset()? Both?
emitSectionOffset should be renamed since it doesn't emit a offset in
all cases. I will email a patch in one sec.
emitAbsoluteSymbolDiff could be renamed to make it more explicit, but
should not include dwarf in the name.
In IRC you suggested emitLabelDifferenceWithoutRelocations. That is
fine and makes it clear it is a bug in the caller if they try to use
in a case where relocations are needed.
Just note that it only suppresses relocation on MachO. On COFF and ELF
it is a general optimization.
More information about the llvm-commits