[PATCH] Replace string GNU Triples with llvm::Triple in TargetMachine. NFC.

Renato Golin renato.golin at linaro.org
Thu Jun 11 04:23:47 PDT 2015


Comments inline.

Otherwise, LGTM. Thanks!


================
Comment at: include/llvm/Target/TargetMachine.h:107
@@ -105,3 +106,3 @@
 
-  StringRef getTargetTriple() const { return TargetTriple; }
+  StringRef getTargetTriple() const { return TargetTriple.str(); }
   StringRef getTargetCPU() const { return TargetCPU; }
----------------
I'd rename this to getTripleName or something like that, to make sure we don't mix with other get Triples that actually return a triple.

This can be in a different patch, though, maybe with a FIXME comment here now.

http://reviews.llvm.org/D10362

EMAIL PREFERENCES
  http://reviews.llvm.org/settings/panel/emailpreferences/






More information about the llvm-commits mailing list