[llvm] r239071 - [bpf] add big- and host- endian support

Eric Christopher echristo at gmail.com
Thu Jun 4 15:37:20 PDT 2015


On Thu, Jun 4, 2015 at 2:31 PM Alexei Starovoitov <
alexei.starovoitov at gmail.com> wrote:

> On Thu, Jun 4, 2015 at 2:17 PM, Quentin Colombet <qcolombet at apple.com>
> wrote:
> >
> >> On Jun 4, 2015, at 2:12 PM, Alexei Starovoitov <
> alexei.starovoitov at gmail.com> wrote:
> >>
> >> On Thu, Jun 4, 2015 at 2:09 PM, Quentin Colombet <qcolombet at apple.com>
> wrote:
> >>>
> >>> On Jun 4, 2015, at 1:53 PM, Alexei Starovoitov
> >>> <alexei.starovoitov at gmail.com> wrote:
> >>>
> >>> On Thu, Jun 4, 2015 at 12:24 PM, Eric Christopher <echristo at gmail.com>
> >>> wrote:
> >>>
> >>> It doesn't look like anyone actually approved this? (I know, it was in
> my
> >>> list of things to look at :)
> >>>
> >>>
> >>> nope. It started to bit rot too quickly, so I pushed it.
> >>>
> >>>
> >>> Please don’t do that. Unless I am mistaken, the review was out only
> for a
> >>> couple of days.
> >>> Here is the review policy, if you want more information.
> >>> http://llvm.org/docs/DeveloperPolicy.html#code-reviews
> >>
> >> hmm, I'm exactly doing the following part:
> >> "(or changes where the developer owns the component) can be reviewed
> >> after commit."
> >
> > Well, in that case, don’t post a review request in the first place :).
>
> :)
> well I mainly wanted to get feedback for logic that
> -march=bpf does _host_ endian.
> I don't think any other backend does things like that.
> What the patch does:
> -march=bpf -> host endian
> -march=bpf_le -> little endian
> -march=bpf_be -> big endian
>
>
So, part of why I was going to review the Triple part of it is that the
naming convention for bpf big and little endian explicit triples doesn't
match the same convention for every other target. So, what references do
you have for these outside of llvm? I'd prefer to copy the existing
nomenclature if there's no compelling reason otherwise.

Thanks.

-eric


> the typical scenario is to compile it on the host,
> load into the kernel and run it there.
> So from ease-of-use point of view it's the best
> (this behavior is specifically what s390 folks have asked)
> but since no other backend does host-endian,
> I wanted to double check and/or argue about it :)
>
> For llvm+bpf backend users it's easier to git pull from main
> tree instead of applying my one-of patches that I'm sending
> them over email and they bit-rot too quickly and fail to apply.
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20150604/d87b07bb/attachment.html>


More information about the llvm-commits mailing list