[PATCH] CodeGen: Use mop_iterator instead of MIOperands/ConstMIOperands
atrick at apple.com
Wed May 27 21:39:27 PDT 2015
I think this is a call that you and Quentin can make. No objections here.
Range based for loops largely obviate the need for another abstraction. It is still convenient to have the operand number, but I won't argue for that.
I wonder if part of the reason for unifying iterators was to gradually migrate passes to operate on bundles. I personally don't think we should support bundles before register coalescing though unless there is a very compelling reason.
It seems that we should also move analyzePhys/VirtReg out of the iterator base class. I don't think calling it on an iterator is a very good API anyway.
More information about the llvm-commits