[PATCH] [Unroll] Rework the naming and structure of the new unroll heuristics.
mzolotukhin at apple.com
Mon May 25 11:13:02 PDT 2015
In general I'm in favor for such changes, but my feeling is that `MaxThreshold` and `Threshold` are still pretty confusing. What about something like `TinyLoopsThreshold` and `BigLoopsThreshold`? The idea is that the `TinyLoopsThreshold` defines which loops are considered tiny (and which we unconditionally unroll), and `BigLoopsThreshold` defines huge loops, which will never be unrolled.
Other than that, the changes look good to me.
And by the way, thanks for your recent patches here!
More information about the llvm-commits