[PATCH] Rename variables in gc_relocate related functions to follow LLVM's naming conventions.

Sanjoy Das sanjoy at playingwithpointers.com
Mon May 11 14:37:22 PDT 2015


LGTM given that this is a renaming-only change.

Do you want me to check this in for you?


================
Comment at: lib/Transforms/Scalar/RewriteStatepointsForGC.cpp:1094
@@ -1093,4 +1093,3 @@
     // only specify a debug name if we can give a useful one
-    Value *reloc = Builder.CreateCall3(
-        gc_relocate_decl, statepointToken, baseIdx, liveIdx,
-        liveVariables[i]->hasName() ? liveVariables[i]->getName() + ".relocated"
+    Value *Reloc = Builder.CreateCall3(
+        GCRelocateDecl, StatepointToken, BaseIdx, LiveIdx,
----------------
Another potential cleanup here -- `CreateCall3` returns a `CallInst` so you can just do

```
Callinst *Reloc = ... CreateCall3
```

and elide of the `cast<>`s.

If you do this, please do that in a separate change.

http://reviews.llvm.org/D9681

EMAIL PREFERENCES
  http://reviews.llvm.org/settings/panel/emailpreferences/






More information about the llvm-commits mailing list