[PATCH] Add new indexed load/store intrinsics.
renato.golin at linaro.org
Wed Apr 22 08:29:52 PDT 2015
In http://reviews.llvm.org/D9194#159975, @HaoLiu wrote:
> If the name of indexed.load indexed.store are not reasonable, how about indexed.gather and indexed.scatter like Elena used in http://reviews.llvm.org/D7665?
I was under the impression that you two would use the same intrinsics, even though the hardware implementation is different, the IR concept should be generic enough to allow scatter/gather, masked loads and indexed loads to be represented in a generic way. Please comment on Elena's patch if you think we should use her intrinsics, but with a more generic name.
I don't want us creating too many load/store intrinsics, as that means poor matching for optimisation passes and make the IR more complex than it should be.
More information about the llvm-commits