[PATCH] New "strict_string_checks" run-time flag

Dmitry Vyukov dvyukov at google.com
Mon Apr 6 00:28:22 PDT 2015


LGTM with a nit
Sorry for the delay, I was on a vacation.


================
Comment at: lib/tsan/rtl/tsan_interceptors.cc:274
@@ -273,1 +273,3 @@
 
+#define TSAN_READ_STRING_OF_LEN(thr, pc, s, len, n)                 \
+  MemoryAccessRange((thr), (pc), (uptr)(s),                         \
----------------
Don't prefix the macros with TSAN_.
Everything in tsan is tsan-something. But prefixing everything with tsan adds whole lot of clutter without adding any value.
READ_STRING is a fine name.

The TSAN_INTERCEPT macros above are prefixed with TSAN_ for historical reasons and should be renamed. Don't look at them.

http://reviews.llvm.org/D7123

EMAIL PREFERENCES
  http://reviews.llvm.org/settings/panel/emailpreferences/






More information about the llvm-commits mailing list