[PATCH] [mips] Implement eliminateCallFramePseudoInstr() in MipsFrameLowering. NFC.

Daniel Sanders daniel.sanders at imgtec.com
Wed Apr 1 11:29:37 PDT 2015


Well spotted. LGTM


================
Comment at: lib/Target/Mips/MipsFrameLowering.cpp:139
@@ +138,3 @@
+                              MachineBasicBlock::iterator I) const {
+  unsigned SP = STI.isABI_N64() ? Mips::SP_64 : Mips::SP;
+
----------------
echristo wrote:
> Should probably get the ABI off of the TargetMachine. I'd like to (or someone should)  remove the subtarget ones at some point and migrate everything to using TM for them.
MipsSubtarget::isABI_N64() is just shorthand for TM.getABI().IsN64() at the moment. It's not that much shorter anymore so I agree we should move to using TM.getABI().IsN64() directly.

We should also rename STI to Subtarget here if the above change doesn't eliminate all the uses.. STI is normally the subtarget flags and not a MipsSubtarget object.

http://reviews.llvm.org/D8641

EMAIL PREFERENCES
  http://reviews.llvm.org/settings/panel/emailpreferences/






More information about the llvm-commits mailing list