[PATCH] Fix sign extension for MIPS64 in makeLibCall function

hfinkel at anl.gov hfinkel at anl.gov
Fri Mar 20 10:21:25 PDT 2015


REPOSITORY
  rL LLVM

================
Comment at: include/llvm/Target/TargetLowering.h:1075
@@ +1074,3 @@
+  /// Returns true if arguments should be sign-extended in ABI calls.
+  virtual bool shouldSignExtendTypeInAbiCall(EVT Type, bool IsSigned) const {
+    return IsSigned;
----------------
This is certainly better, my only issue now is with the function name. The term 'ABI call' seems ambiguous (and appears in the Mips backend, but nowhere else in the same way), and this specifically applies to calls generated with makeLibCall. How about naming it?
  shouldSignExtendTypeInLibCall
which seems to fit better with general LLVM terminology.

http://reviews.llvm.org/D7791

EMAIL PREFERENCES
  http://reviews.llvm.org/settings/panel/emailpreferences/






More information about the llvm-commits mailing list