[PATCH] [mips] [IAS] Improve warning for using AT with .set noat.
toma.tabacu at imgtec.com
Fri Mar 20 05:11:24 PDT 2015
Changed the warning message to use "aka" for the value of $at, similar to what clang does for typedef's,
and renamed warnIfAssemblerTemporary to a more descriptive name.
I also changed the type of variables which store registers from int to unsigned, updated the relevant test
and tried to make the related comments clearer.
-------------- next part --------------
A non-text attachment was scrubbed...
Size: 4250 bytes
Desc: not available
More information about the llvm-commits