[PATCH] Add invoke statepoint placement tests

Ramkumar Ramachandra artagnon at gmail.com
Sat Feb 14 11:38:28 PST 2015


REPOSITORY
  rL LLVM

================
Comment at: test/Transforms/PlaceSafepoints/invokes.ll:3
@@ +2,3 @@
+
+declare i64 addrspace(1)* @"some_call"(i64 addrspace(1)*)
+declare i32 @"personality_function"()
----------------
Why did you quote some_call? Doesn't it look ugly?

================
Comment at: test/Transforms/PlaceSafepoints/invokes.ll:6
@@ +5,3 @@
+
+define i64 addrspace(1)* @test1(i64 addrspace(1)* %obj, i64 addrspace(1)* %obj1) {
+; CHECK-LABEL: entry:
----------------
It might be nice to give the test a more descriptive name than testN.

================
Comment at: test/Transforms/PlaceSafepoints/invokes.ll:10
@@ +9,3 @@
+  ; CHECK: invoke
+  ; CHECK: statepoint
+  %ret_val = invoke i64 addrspace(1)* @"some_call"(i64 addrspace(1)* %obj)
----------------
Do check for gc.statepoint.<sig>, because you don't know if you're matching a poll or a callsite in the original.

http://reviews.llvm.org/D7535

EMAIL PREFERENCES
  http://reviews.llvm.org/settings/panel/emailpreferences/






More information about the llvm-commits mailing list