[PATCH] IR: Add specialized debug info metadata nodes
friss at apple.com
Wed Feb 4 15:53:01 PST 2015
> On Feb 4, 2015, at 3:46 PM, Duncan P. N. Exon Smith <dexonsmith at apple.com> wrote:
>> On 2015-Feb-04, at 15:37, Frédéric Riss <friss at apple.com> wrote:
>>>> - The word 'context' is overloaded: `MDNode::getContext()` already
>>>> exists, and returns an `LLVMContext&`; `DIDescriptor` uses 'context'
>>>> to mean "the node that this one is defined inside". I chose the
>>>> word 'parent' instead of 'context' here. Is this word okay? If
>>>> not, what about 'scope'? This will be reflected in the assembly
>>>> changes to come (I'd like the C++ names to match the assembly names,
>>>> although technically it's not necessary).
>>>> I'd /probably/ go with scope (we already have scope in the MDLocations, so that seems consistent), but fairly on-the-fence.
>>> Weirdly, I didn't even notice that :). In that case I like 'scope'
>>> better too. I'll update to that before commit.
>> Seems most natural. Can the futur getScope() return something that doesn’t derive from MDScope?
> I don't think so.
That was my impression also, and it makes it even more appropriate IMHO.
More information about the llvm-commits