[PATCH] Modularizing LICM

Philip Reames listmail at philipreames.com
Tue Feb 3 09:34:30 PST 2015


With comments by others addressed, LGTM.


REPOSITORY
  rL LLVM

================
Comment at: lib/Transforms/Scalar/LICM.cpp:410
@@ +409,3 @@
+                             MayThrow, HeaderMayThrow) &&
+          isSafeToExecuteUnconditionally(I, DT, DL, CurLoop, 
+                                         MayThrow, HeaderMayThrow))
----------------
This name is fine for now, but if this is exposed somewhere outside of LICM we'll need a clearer name.  This isn't "safe to execute anywhere" its "safe to execute in the preheader".

http://reviews.llvm.org/D7291

EMAIL PREFERENCES
  http://reviews.llvm.org/settings/panel/emailpreferences/






More information about the llvm-commits mailing list