[PATCH] [ELF] Implement semantic action for ENTRY linker script command

Rui Ueyama ruiu at google.com
Sat Jan 31 19:14:42 PST 2015


LGTM


REPOSITORY
  rL LLVM

================
Comment at: lib/Driver/GnuLdDriver.cpp:292
@@ -291,1 +291,3 @@
       ctx.addSearchPath(searchDir->getSearchPath());
+    if (auto *entrySymbol = dyn_cast<script::Entry>(c))
+      ctx.setEntrySymbolName(entrySymbol->getEntryName());
----------------
nit: I'd choose a shorter name for entrySymbol, like e or entry, because the scope of the variable is very short (two lines).

http://reviews.llvm.org/D7319

EMAIL PREFERENCES
  http://reviews.llvm.org/settings/panel/emailpreferences/






More information about the llvm-commits mailing list