[PATCH] [lld][ARM] Add relocations to perform function calls
dprotivensky at accesssoftek.com
Wed Jan 28 02:37:26 PST 2015
Comment at: lib/ReaderWriter/ELF/ARM/ARMRelocationHandler.cpp:161
@@ +160,3 @@
+ const bool exchanges = !addressesThumb;
> denis-protivensky wrote:
> > wnewton wrote:
> > >
> > > "addressesThumb" is IMO a more descriptive name than "exchanges" so this variable does not help me to read the code.
> > I also doubted about this name, but I'd like to introduce some variable to point that addressing Thumb (or ARM) code for some instructions means 'exchange instruction set'. Any ideas about better name?
Thanks! This sounds much better. Will update shortly.
More information about the llvm-commits