[PATCH] Remove kindInGroup reference

Shankar Kalpathi Easwaran shankarke at gmail.com
Tue Jan 27 13:23:35 PST 2015


Sorry to club this in the current review thread, I think we are overloading the Layout references for garbage collection.

If you are creating a reference (kindLayoutAfter) from A to B, that may not mean that you cannot garbage collect B for the end user.

My thought on Layout references was that it only guarantees that atoms appear in Layout reference order.

Why are we overloading this for Garbage collection (aside from saving space/code) ?

We should create kindLive (or) some better name IMO for Garbage collection. With this the complex LayoutPass can be optional and would be meant only for users that need the LayoutReferences to specify layout of the image.

We could come up with a simpler pass for Layout(to sort atoms by file ordinal).

What do you think ?


http://reviews.llvm.org/D7189

EMAIL PREFERENCES
  http://reviews.llvm.org/settings/panel/emailpreferences/






More information about the llvm-commits mailing list