[PATCH] [MSan] [MIPS] Adding support for MIPS64

Mohit Bhakkad mohit.bhakkad at imgtec.com
Sun Nov 16 22:50:32 PST 2014


================
Comment at: lib/msan/msan_report.cc:58
@@ +57,3 @@
+      pc += 1;
+    #elif defined(__mips64)
+      pc += 8;
----------------
kcc wrote:
> I'd prefer not to have #ifdef here. 
> At the very least, move it into a separate function near the StackTrace::GetPreviousInstructionPc
> but I would like to understand why we need this adjustment here at all. 
I don't know the reason for this adjustment.
I will submit a new revision with a function StackTrace::GetNextInstructionPc in 
sanitizer_stacktrace.cc, once http://reviews.llvm.org/D6268 gets commited.

http://reviews.llvm.org/D5906






More information about the llvm-commits mailing list