[PATCH] Move DWARFUnitSection from the vector API to something more semantically accurate.

Frederic Riss friss at apple.com
Tue Sep 16 22:47:13 PDT 2014


The Units method was suggested by Alexey I have no strong feeling either way. With this patch applied, the inheritance of SmallVector isn't necessary anymore, I didn't fold the move from inheritance to composition in this patch, but it could be done.

The next step for me is to factor the the parsing code into this class. There is an intermediate step though: the actual code is semantically wrong when it comes to type units. Type units might come from different sections, but we put them all in the same DWARFUnitSection object. Once this is fixed, we can move parsing into DWARFUnitSection and remove at least the addUnit method.

Once this is done a bunch of accessors from the context can go away also.

http://reviews.llvm.org/D5369






More information about the llvm-commits mailing list