[llvm] r217751 - Fix ambiguous typedef introduced in r217747.

Frederic Riss friss at apple.com
Mon Sep 15 01:23:07 PDT 2014


Author: friss
Date: Mon Sep 15 03:23:07 2014
New Revision: 217751

URL: http://llvm.org/viewvc/llvm-project?rev=217751&view=rev
Log:
Fix ambiguous typedef introduced in r217747.

Use fully qualified name inside a typedef from llvm::iterator_range<...> to
iterator_range. This is reported (rightly I think) by GCC as an
ambiguous name redefinition. Hope this fixes the buildbots.

Modified:
    llvm/trunk/lib/DebugInfo/DWARFUnit.h

Modified: llvm/trunk/lib/DebugInfo/DWARFUnit.h
URL: http://llvm.org/viewvc/llvm-project/llvm/trunk/lib/DebugInfo/DWARFUnit.h?rev=217751&r1=217750&r2=217751&view=diff
==============================================================================
--- llvm/trunk/lib/DebugInfo/DWARFUnit.h (original)
+++ llvm/trunk/lib/DebugInfo/DWARFUnit.h Mon Sep 15 03:23:07 2014
@@ -58,9 +58,9 @@ class DWARFUnitSection : public SmallVec
   };
 
 public:
-  typedef SmallVectorImpl<std::unique_ptr<UnitType>> UnitVector;
+  typedef llvm::SmallVectorImpl<std::unique_ptr<UnitType>> UnitVector;
   typedef typename UnitVector::iterator iterator;
-  typedef iterator_range<typename UnitVector::iterator> iterator_range;
+  typedef llvm::iterator_range<typename UnitVector::iterator> iterator_range;
 
   UnitType *getUnitForOffset(uint32_t Offset) const {
     auto *CU = std::lower_bound(this->begin(), this->end(), Offset,





More information about the llvm-commits mailing list