[PATCH] Select elimination pass

Gerolf Hoflehner ghoflehner at apple.com
Wed Sep 3 20:41:48 PDT 2014


Select Elimination Pass update

Improved readability and addressed review:
- moved code that replaces select into a function replaceSelectWithOr()
- moved the checks for the selection condition compare into functio isChainSelectCmpEQBranch().
- cleared up some clutter as David M. had suggested

http://reviews.llvm.org/D5156

Files:
  bindings/ocaml/transforms/scalar/scalar_opts_ocaml.c
  include/llvm-c/Transforms/Scalar.h
  include/llvm/InitializePasses.h
  include/llvm/LinkAllPasses.h
  include/llvm/Transforms/Scalar.h
  lib/LTO/LTOCodeGenerator.cpp
  lib/Transforms/IPO/PassManagerBuilder.cpp
  lib/Transforms/Scalar/CMakeLists.txt
  lib/Transforms/Scalar/Scalar.cpp
  lib/Transforms/Scalar/SelectElimination.cpp
  test/Transforms/SelectElim/
  test/Transforms/SelectElim/select-elim-or.ll
-------------- next part --------------
A non-text attachment was scrubbed...
Name: D5156.13238.patch
Type: text/x-patch
Size: 14654 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20140904/93bce92b/attachment.bin>


More information about the llvm-commits mailing list