[PATCH] rename _LIBCPP_TYPE_VIS_ONLY to _LIBCPP_TEMPLATE_VIS
rjmccall at apple.com
Tue Sep 2 19:46:23 PDT 2014
On Sep 2, 2014, at 2:01 PM, Reid Kleckner <rnk at google.com> wrote:
I like the idea of renaming the macro, but (1) you should preserve the type vs. function difference in the name and (2) you should rename _LIBCPP_FUNC_VIS_ONLY as well.
So, I would suggest _LIBCPP_TEMPLATE_TYPE_VIS and _LIBCPP_TEMPLATE_FUNC_VIS.
Also, please don’t strip the annotations completely. If the correct axis is template vs. non-template — and I think that’s correct — then you should be adding _LIBCPP_TYPE_VIS to the types.
Otherwise seems fine to me.
More information about the llvm-commits