[PATCHES] remove last uses of naked mutexes

David Blaikie dblaikie at gmail.com
Sat Aug 23 13:38:56 PDT 2014


Keep the STL name if its basically a copy of that code.

Pick whichever scoped lock has more uses (hopefully the older one) and
canonicalize on that, probably (but could be done in a separate preliminary
patch)
On Aug 23, 2014 12:50 PM, "Dylan Noblesmith" <nobled at dreamwidth.org> wrote:

> There are a few places in LLVM that have weird conditional unlocking
> and a ScopedLock simply doesn't fit.
>
> So this adds a minimal variation of std::unique_lock to accommodate
> those use cases. I just named it llvm::unique_lock since it copied the
> STL-- should it still use CamelCase instead?
>
> I also noticed that MutexGuard predates SmartScopedLock, but offers a
> subset of its features aside from a method 'holds()' that has no
> users, so it's basically duplicated code. But which name should be
> kept as the canonical typedef, ScopedLock or MutexGuard?
>
> _______________________________________________
> llvm-commits mailing list
> llvm-commits at cs.uiuc.edu
> http://lists.cs.uiuc.edu/mailman/listinfo/llvm-commits
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20140823/704671c9/attachment.html>


More information about the llvm-commits mailing list