[PATCH] Optimize InstCombine stack memory consumption

Marcello Maggioni hayarms at gmail.com
Tue Jul 1 14:35:27 PDT 2014


================
Comment at: lib/Transforms/InstCombine/InstCombineLoadStoreAlloca.cpp:63
@@ +62,3 @@
+    const bool IsOffset = ValuePair.second;
+    for (auto &Use : ValuePair.first->uses()) {
+      Instruction *I = cast<Instruction>(Use.getUser());
----------------
Reid Kleckner wrote:
> Why rename 'U' to 'Use'?  'Use' already a type, so this is a bit confusing.  If anything, this loop should iterate over users, not uses.
Thank you Reid, I agree with what you say. I fixed it in the next revision

http://reviews.llvm.org/D4355






More information about the llvm-commits mailing list